Answered By: Reference Staff
Last Updated: Oct 13, 2021     Views: 6

As of September 30, 2021, users of Libby and OverDrive will encounter problems when using older systems. OverDrive informed us that their Web Certificate Provider no longer supports older browsers and operating systems.

This means if you have an older device and it is running an operating system older than iOS 10 or MacOS 10.12.1, you will experience problems using the app and possibly see error messages. You may not even be able to finish setting up your account or log in to your existing account. This can also happen with computers using older browsers.

Affected OverDrive sites and apps:

  • Libby App (iOS and Android)
  • libbyapp.com
  • OverDrive App (Mobile and Desktop)
  • OverDrive.com

To fix this, browsers and operating systems on your device need to be updated. Unfortunately, some older devices will not be able to update to a recent enough version (for example, some older iPads are unable to update to iOS 10 or later).

If updates are not performed on your device, there can be a security issue and your data could be compromised since OverDrive can’t confirm your connection is secure.

More information directly from OverDrive/Libby is available on their help pages.